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Do you want to know how to make a header in Excel? Or are you wondering how to add the footer page 1 to the current worksheet? This tutorial will teach you how to quickly insert one of the predefined headers and footers and how to create a custom one with your own text and graphics. To make your printed Excel documents look more stylish and
professional, you can include a header or footer on each page of your worksheet. Generally, headers and footers contain basic information about the spreadsheet such as page number, current date, workbook name, file path, etc. Microsoft Excel provides a handful of predefined headers and footers to choose from, as well as allows creating your own
ones. Headers and footers are displayed only on printed pages, in Print Preview and Page Layout view. In the normal worksheet view, they are not visible. Inserting a header in an Excel worksheet is quite easy. Here's what you do: Go to the Insert tab > Text group and click the Header & Footer button. This will switch the worksheet to Page Layout
view. Now, you can type text, insert a picture, add a preset header or specific elements in any of the three Header boxes at the top of the page. By default, the central box is selected: If you wish the header to appear in the top left or top right corner of the page, click the left or right box and enter some information there. When finished, click
anywhere in the worksheet to leave the header area. To exit the header box without keeping the changes, press Esc. When you print out your worksheet, the header will be repeated on each page. Like an Excel header, a footer can also be inserted in a few easy steps: On the Insert tab, in the Text group and click the Header & Footer button. On the
Design tab, click Go to Footer or scroll down to the footer boxes at the bottom of the page. Depending on the desired location, click the left, center, or right footer box, and type some text or insert the element you want. To add a preset footer, please follow these steps, to make a custom Excel footer, see these guidelines. When done, click anywhere in
the worksheet to exit the footer area. For example, to insert page numbers at the bottom of the worksheet, select one of the footer boxes and click Page Number on the Design tab, in the Header & Footer group. Microsoft Excel comes equipped with a number of inbuilt headers and footers that can be inserted in your document in a mouse click. Here's
how: On the Insert tab, in the Text group, click Header & Footer. This will display the worksheet in Page Layout view and get the Design tab to appear. On the Design tab, in the Header & Footer group, click the Header or Footer button, and select the built-in header or footer of your choosing. As an example, let's insert a footer that displays a page
number and file name: Voila, our Excel footer is created, and the following information will be printed at the bottom of each page: When inserting an inbuilt header or footer in Excel, please be aware of the following caveats. Most of the preset headers and footers in Excel are entered as codes, which makes them dynamic - meaning your header or
footer will change to reflect the latest changes you make to the worksheet. For example, the code &[Page] inserts different page numbers on each page and &[File] displays the current file name. To see the codes, just click the corresponding header or footer text box. If you have chosen to add a complex header or footer, chances are that different
elements will be inserted in different boxes like in the above example: When adding a built-in header or footer, you cannot control the location of specific elements - they are inserted in the predefined boxes no matter which box (left, center, or right) is currently selected. To position the header or footer the way you want, you can move the inserted
elements to other boxes by copying / pasting their codes or add each element individually as explained in the next section. In Excel worksheets, not only can you add preset headers and footers, but also make your own ones with custom text and images. As usual, you start by clicking the Header & Footer button on the Insert tab. Then, click one of the
boxes at the top (header) or at the bottom (footer) of the worksheet and type your text there. You can also enter different pieces of information by selecting one of the built-in elements on the Design tab, in the Header & Footer Elements group. This example will show you how to create a custom header with your company logo, page numbers, file
name and current date. To begin with, let's insert File Name (workbook name) in the central header box: Then, select the right box and insert Page Number there. As you can see in the screenshot below, this only displays the number: If you want the word "Page" to appear as well, click anywhere in the right text box, and type "Page" in front of the
code, separating the word and the code with a space character like this: Additionally, you can insert the Number of Pages element in the same box by clicking on the corresponding button on the ribbon, and then type "of" in between the codes so that your Excel header displays something like "Page 1 of 3": Finally, let's insert the company logo in the
left box. For this, click the Picture button, browse for the image file, and click Insert. The &[Picture] code will be inserted in the header straight away: As soon as you click anywhere outside the header box, an actual picture will show up. Our custom Excel header looks pretty nice, don't you think? Tips: To start a new line in a header or footer box,
press the Enter key. To include an ampersand (&) in the text, type two ampersand characters without spaces. For example, to include Products & Services in the header or footer, you type Products && Services. To add page numbers to Excel headers and footers, insert the &[Page] code in combination with any text you want. For this, use the built-in
Page Number element or one of the preset headers and footers. If you enter the numbers manually, you will end up having the same number on each page. If case you'd like to create a header or footer for chart sheets or for several worksheets at a time, the Page Setup dialog box is your option. Select one or more worksheets for which you'd like to
make a header or footer. To select multiple sheets, hold down the Ctrl key while clicking the sheet tabs. Go to the Page Layout tab > Page Setup group and click the Dialog Box Launcher. The Page Setup dialog box will show up where you can select one of the preset headers and footers or make your own one. To insert a preset one, click the drop-
down arrow in the Header or Footer box and choose from the available options. For example: To create a custom header or footer, do the following: Click the Custom Header... or Custom Footer... button. Select the left, center or right section box, and then click one of the buttons above the sections. To find out exactly what element a particular button
inserts, hover over it to display a tooltip. For example, this is how you can add a page number to the right hand side of your Excel header: You can also type your own text in any section as well as edit or remove the existing text or codes. When finished, click OK. Tip. To see how your header or footer will look like on a printed page, click the Print
Preview button. There are two ways to edit headers and footers in Excel - in Page Layout view and by using Page Setup dialog. To switch to Page Layout view, go to the View tab > Workbook Views group, and click Page Layout. Or, click the Page Layout button on the status bar in the bottom-right corner of the worksheet: Now, you select the header
or footer text box and make the desired changes. Another way to modify an Excel footer or header is by using the Page Setup dialog box. Please remember that a header and footer of chart sheets can only be edited in this way. Once you have finished creating or editing your Excel footer or header, how do you get out of the header and footer view and
return to the regular view? By doing any of the following: On the View tab > Workbook Views group, click Normal. Or, just click the Normal button on the status bar. To remove an individual header or footer, simply switch to Page Layout view, click the header or footer text box, and press the Delete or Backspace key. To delete headers and footers
from multiple worksheets at once, carry out these steps: Select the worksheets from which you want to remove a header or footer. Open the Page Setup dialog box (Page Layout tab > Page Setup group > Dialog Box Launcher). In the Page Setup dialog box, click the drop-down arrow to open the list of preset headers or footers, and select (none). Click
OK to close the dialog box. That's it! All headers and footers in the selected sheets will be removed. Now that you know the essentials of Excel headers and footers, the below tips may help you avoid common challenges. To insert headers or footers on multiple worksheets at a time, select all target sheets, and then add a header or footer in the usual
way. To select multiple adjacent worksheet, click the tab of the first sheet, hold down the Shift key, and click the tab of the last sheet. To select multiple non-adjacent sheets, hold down the Ctrl key while clicking the sheet tabs individually. To select all worksheets, right-click any sheet tab, and choose Select All Sheets from the context menu. Once the
worksheets are selected, go to the Insert tab > Text group > Header & Footer and enter the header or footer information as you like. Or insert a header/footer via the Page Setup dialog. When finished, right click any unselected sheet to ungroup the worksheets. If all of the sheets are selected, click any sheet tab, and then click Ungroup Sheets in the
context menu. To quickly change the font style or font color of your header or footer, select the text and pick the desired formatting option in the pop-up window: Alternatively, select the header or footer text you want to change, head to the Home tab > Font group and select the formatting options you want. If you'd like to insert a specific header or
footer on the first page of your worksheet, you can have it done in this way: Change to Page Layout view. Select the header or footer. Go to the Design tab, and check the Different First Page box. Set up a special header or footer for the first page. Tip. If you want to create separate headers or footers for odd and even pages, select the Different Odd &
Even Pages box, and enter different information on page 1 and page 2. To keep the font size of the header or footer text intact when the worksheet is scaled for printing, switch to Page Layout view, select the header or footer, go to the Design tab and clear the Scale with Document box. If you leave this checkbox selected, the header and footer font
will scale with the worksheet. For example, the header text will become smaller when you select the Fit Sheet on One Page printing option. That's how you add, change and remove headers and footers in Excel. I thank you for reading and hope to see you on our blog next week. Steps: Choose the frame right inside the row and column to create
headers. Select the corner cell of the area you want unlocked. We selected the cell Harry to freeze the upper panes. In the View tab, choose the Freeze Panes option. This will freeze the rows above the selected cell and the columns. Read More: How to Change Column Headings in Excel Method 2 - Printing a Header Row to Create Column Headers
Steps: Select the Page Layout tab. Make sure that the cells in which the data is included are selected as the Print Area. Click the button located next to the Print Area box, move the selection so that it covers the data that you want to print. Click Rows to repeat at top. This will choose row(s) to treat as the header. Choose the row(s) you wish to make a
header for. The rows you choose will be at the top of every printed page. This is useful to make large spreadsheets accessible over numerous pages. Click on Rows to repeat at top. This will let you choose which row(s) to treat as the constant header. Then, choose the row(s) you wish to make a header for. The rows you choose will be at the top of
every printed page. This is particularly useful for making huge spreadsheets accessible over numerous pages. Click the button next to Columns to repeat at left. This will allow you to select columns that you want to keep constant on each page. You can print the sheet. Excel will use the constant heading and the columns you selected in the Print Titles
box to print the data that you specified. Read More: How to Remove Column Headers in Excel Method 3 - Creating Column Headers by Formatting as a Table Steps: Choose the information you want to put into a table. Click the Insert tab and select the Table option. Check the My table has headers box and click OK. The first row will automatically
become column headers. The table will be like the image below. Read More: How to Rename Column in Excel Things to Remember Format column heads differently and use Freeze Panes to always see them. It saves time by reducing scrolling. Print using Print Area and Rows to repeat at every page. Excel Tables need definite range and column
headings. Download the Practice Workbook Create Column Headers.xlsx Related Articles Workbook Views group > Page Layout. The worksheet will transform to the Page Layout view with the Header visible at the top of the sheet. We can see ‘Microsoft Excel’ in the Center Section of the Header box. To change the header, simply delete the previous
text and type new text. Here, we have typed ‘How to add Header’ instead of ‘Microsoft Excel’. Read More: How to Insert Logo in Excel Header How to Close a Header in Excel We often need to exit the header and footer view and return to the regular view after finishing adding the Excel header. Suppose we have a dataset (B4:F8) in Excel where we
have added a header named ‘Microsoft Excel’. We can close the Header by shifting from the Page Layout view to the Normal view. Steps: Go to the View tab > Workbook Views > Normal. We have closed the Header successfully. How to Remove a Header in Excel Suppose we have the dataset below where we have inserted a header. Let’s remove the
header. Steps: Go to the View tab and select Page Layout from the Workbook Views group. The Header will appear. Select the Header text box. Press the Delete or Backspace key on the keyboard and the header will be removed. Advantages of Using Headers in Excel Headers help the layout to look more professional and save time by eliminating the
need to change the header of each sheet manually. Things to Keep in Mind When we add a Header in Excel, it is carried forward to all sheets. If you need to change any individual sheet’s Header, go to that sheet’s Header to make the required changes. Download Practice Workbook Related Articles



